Jump to content

User Scenarios Won't Load


b17racerX

Recommended Posts

I get a couple of different errors when trying to load user scenarios in HCE. 

GetMemAnnexA Error: !!S_Disk.  The message has been logged.  The Program will now terminate.

or

The requested scenario file requires a newer version of the game.  This scenario is version 5.  This games supports through version 3.  Exiting.   (game says no updates are available)

 

Any help getting these scenarios to load would be appreciated.

Link to comment
Share on other sites

Hi Racer

Some User related scenarios do require the latest version and  certain DB. I you can tell me what DB and Scenario you are trying to load I might be able to help you. Also need to know which version you are running. The version should show up at the top left of the page. It will be a year then update number like 2020.009 which is the latest version.

 

Link to comment
Share on other sites

Thanks for the quick reply.

My version of HUCE is (was) 2015.027, but when I ran the update utility is says it's the latest version.   I found the 2020.009 (Beta) version on the forum, but when I installed it gave me registration errors.  Now, when I re-install the 2015.027 version it can't find harpoon32.dll.  Seems I've made it worse.

Database is (was) HCDB2 170909  or HCDB 150928

Some examples of the scenarios I can't load:  Sea Breeze 2017, Spratly Island #3

 

 

Link to comment
Share on other sites

Good now here is where you probably need to go from there. Some of the latest scenarios do require a later version of the game which is referred to as a Beta version which is the work of individuals to keep improving the game. 2015.027 is the latest official updated version from Matrix. The version you are at is not recent enough version to run those scenarios as they were made with an even later version. There is an order to loading up the later version which should alleviate all you problems. The order to load the latest version will require that after you load up to 2015.009 you will need to follow this short order to get the latest version to word properly. Follow this order after updating to 2015.027. You can go directly there by clicking on Current Files in the window below. I will check here to see if it gets you up and running. 

 

Link to comment
Share on other sites

Once you have gotten the latest version downloaded and running you will need one more download. Go here and type on the highlighted words in the window below. This corrects a quirk that happens when updating to the latest version. It should run automatically and fix the formation editor problem.

 

 

Link to comment
Share on other sites

I need to know which DB and scenario you are trying to use. Right now it looks like a mismatched DB to scenario. If need be we can bring to you a chat and work with you directly. There are a few scenarios that are DB specific. One more question can you run the older battle set scenarios prior to Battle set for 2003. Need to know if the game runs at all. If it does then load the data base 150928 and try running the later Battle

set scenarios listed.

 

 

 

 

 

 

Link to comment
Share on other sites

I re-loaded the 150928 database, but that didn't change anything.  All the older battleset scenarios that come with HUCE work fine, as do about 80% of the user scenarios.  There are just a handful that give this error.   HB4, HB5, Spratly#3, BBB, and others.  They all give an error like the attached image, though the numbers after DISK vary.

Screenshot 2020-09-27 193216.jpg

Link to comment
Share on other sites

Good Evening,

For us to help you out we need some information.

At the bottom right of the screen next to the time there block that shows the version of the HC database you are using.

The current version of the Official HC database is HCCW-140314 (1950-75 era).

What is the current version of the database you are using?

It looks like you have got the latest version of HC  2020.009.

Please let us know.

Eric

Link to comment
Share on other sites

Ok that is good. Now please load DB 170909 and try the ones that you got the error with again. I am thinking the ones you are specifying or 170909 specific. I tested the ones you mentioned. Now the Spratly three one you called has a very specific DB and that author would be the one in this thread now.

 

Link to comment
Share on other sites

Ok HB4 HB5 and BBB are 170909 specific. Most of the latest 170909 specific. Those should run with 170909 loaded. If you have trouble with any scenario let me know which one and I most likely can help you with it. Now if you wish to edit any scenario you will need the required DB also installed.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...